Re: [PATCH 08/18] util: storagefile: Rename "canonPath" to "path" in virStorageFileMetadata

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On 04/20/2014 04:13 PM, Peter Krempa wrote:
> As for the previous patch, this change is needed to achieve
> compatibility with all the existing code, where we expect a fully
> qualified path of local files to be present.
> ---
>  src/util/virstoragefile.c | 18 +++++++--------
>  src/util/virstoragefile.h |  2 +-
>  tests/virstoragetest.c    | 56 +++++++++++++++++++++++------------------------
>  3 files changed, 38 insertions(+), 38 deletions(-)

> +++ b/src/util/virstoragefile.c
> @@ -948,7 +948,7 @@ virStorageFileMetadataNew(const char *path,
>      if (VIR_STRDUP(ret->relPath, path) < 0)
>          goto error;
> 
> -    if (!(ret->canonPath = canonicalize_file_name(path))) {
> +    if (!(ret->path = canonicalize_file_name(path))) {

Another merge conflict with my earlier squash-in requests.  Should be an
obvious fix.

Mechanical; ACK.


> +++ b/tests/virstoragetest.c
> @@ -237,7 +237,7 @@ struct _testFileData
>      bool expEncrypted;
>      const char *pathRel;
>      const char *pathAbs;
> -    const char *canonPath;
> +    const char *path;

I'm not sure I would have renamed this field.  But I guess it doesn't hurt.

-- 
Eric Blake   eblake redhat com    +1-919-301-3266
Libvirt virtualization library http://libvirt.org

Attachment: signature.asc
Description: OpenPGP digital signature

--
libvir-list mailing list
libvir-list@xxxxxxxxxx
https://www.redhat.com/mailman/listinfo/libvir-list

[Index of Archives]     [Virt Tools]     [Libvirt Users]     [Lib OS Info]     [Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Big List of Linux Books]     [Yosemite News]     [KDE Users]     [Fedora Tools]