Re: [PATCH 2/n] conf: split network host structs to util/

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On 03/27/14 00:09, Eric Blake wrote:
> Continuing the refactoring of host-side storage descriptions out
> of conf/domain_conf and into util/virstoragefile, this patch
> focuses on details about a host name/port/transport as used by
> a network storage volume.
> 
> * src/conf/domain_conf.h (virDomainDiskProtocolTransport)
> (virDomainDiskHostDef, virDomainDiskHostDefClear)
> (virDomainDiskHostDefFree, virDomainDiskHostDefCopy): Move...
> * src/util/virstoragefile.h (virStorageNetHostTransport)
> (virStorageNetHostDef, virStorageNetHostDefClear)
> (virStorageNetHostDefFree, virStorageNetHostDefCopy): ...here,
> with better names.
> * src/util/virstoragefile.c (virStorageNetHostDefClear)
> (virStorageNetHostDefFree, virStorageNetHostDefCopy): Moved from...
> * src/conf/domain_conf.c (virDomainDiskHostDefClear)
> (virDomainDiskHostDefFree, virDomainDiskHostDefCopy): ...here.
> (virDomainDiskSourceDefClear, virDomainDiskSourceDefParse)
> (virDomainDiskSourceDefFormatInternal): Adjust callers.
> * src/conf/snapshot_conf.h (_virDomainSnapshotDiskDef): Likewise.
> * src/conf/snapshot_conf.c (virDomainSnapshotDiskDefClear):
> Likewise.
> * src/qemu/qemu_command.c (qemuAddRBDHost)
> (qemuParseDriveURIString, qemuParseNBDString)
> (qemuBuildNetworkDriveURI, qemuParseCommandLineDisk)
> (qemuParseCommandLine, qemuGetDriveSourceString): Likewise.
> * src/qemu/qemu_command.h: Likewise.
> * src/qemu/qemu_conf.c (qemuAddISCSIPoolSourceHost)
> (qemuTranslateDiskSourcePool): Likewise.
> * src/qemu/qemu_driver.c
> (qemuDomainSnapshotCreateSingleDiskActive)
> (qemuDomainSnapshotUndoSingleDiskActive): Likewise.
> * src/storage/storage_backend_gluster.c
> (virStorageFileBackendGlusterInit): Likewise.
> * src/storage/storage_driver.c (virStorageFileFree)
> (virStorageFileInitInternal): Likewise.
> * src/storage/storage_driver.h (_virStorageFile): Likewise.
> * src/libvirt_private.syms (domain_conf.h): Move symbols...
> (virstoragefile.h): ...as appropriate.
> 
> Signed-off-by: Eric Blake <eblake@xxxxxxxxxx>
> ---
>  src/conf/domain_conf.c                | 88 +++++------------------------------
>  src/conf/domain_conf.h                | 28 ++---------
>  src/conf/snapshot_conf.c              |  5 +-
>  src/conf/snapshot_conf.h              |  4 +-
>  src/libvirt_private.syms              | 10 ++--
>  src/qemu/qemu_command.c               | 38 +++++++--------
>  src/qemu/qemu_command.h               |  6 +--
>  src/qemu/qemu_conf.c                  |  4 +-
>  src/qemu/qemu_driver.c                | 24 +++++-----
>  src/storage/storage_backend_gluster.c |  8 ++--
>  src/storage/storage_driver.c          |  8 ++--
>  src/storage/storage_driver.h          |  2 +-
>  src/util/virstoragefile.c             | 71 +++++++++++++++++++++++++++-
>  src/util/virstoragefile.h             | 30 +++++++++++-
>  14 files changed, 167 insertions(+), 159 deletions(-)
> 

Unpleasant amount of fallout from these changes :/.. ACK

Peter


Attachment: signature.asc
Description: OpenPGP digital signature

--
libvir-list mailing list
libvir-list@xxxxxxxxxx
https://www.redhat.com/mailman/listinfo/libvir-list

[Index of Archives]     [Virt Tools]     [Libvirt Users]     [Lib OS Info]     [Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Big List of Linux Books]     [Yosemite News]     [KDE Users]     [Fedora Tools]