Re: [PATCH 1/7] Rename 'clone' to 'cloneFrom' to avoid name clash with clone() syscall

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On 03/07/13 17:41, Daniel P. Berrange wrote:
From: "Daniel P. Berrange" <berrange@xxxxxxxxxx>

On RHEL-4 vintage one of the header files is polluted causing a
clash between the clone() syscall and the 'clone' parameter in
a libvirt driver API

Signed-off-by: Daniel P. Berrange <berrange@xxxxxxxxxx>
---
  src/driver.h | 2 +-
  1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/src/driver.h b/src/driver.h
index f60bf93..0931be2 100644
--- a/src/driver.h
+++ b/src/driver.h
@@ -1443,7 +1443,7 @@ typedef char *
  typedef virStorageVolPtr
      (*virDrvStorageVolCreateXMLFrom)         (virStoragePoolPtr pool,
                                                const char *xmldesc,
-                                              virStorageVolPtr clone,
+                                              virStorageVolPtr clonefrom,

libvirt.c uses "clonevol" here.

                                                unsigned int flags);
  typedef int
      (*virDrvStorageVolDownload) (virStorageVolPtr vol,


ACK the name in the header isn't that important.

Peter

--
libvir-list mailing list
libvir-list@xxxxxxxxxx
https://www.redhat.com/mailman/listinfo/libvir-list


[Index of Archives]     [Virt Tools]     [Libvirt Users]     [Lib OS Info]     [Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Big List of Linux Books]     [Yosemite News]     [KDE Users]     [Fedora Tools]