On Tue, Jan 08, 2013 at 04:41:58PM -0700, Eric Blake wrote: > On 01/08/2013 02:36 PM, Doug Goldstein wrote: > > I often find myself doing virsh "define blah.xml; start blah". I figured > > adding this would be a easier^Hlazier way to do it. > > --- > > tools/virsh-domain.c | 20 ++++++++++++++++++-- > > 1 files changed, 18 insertions(+), 2 deletions(-) > > Offhand, I like it. However, > > We have virDomainDefineXML with no flags, but we have virDomainCreateXML > with flags; maybe the better approach is to add a new creation flag that > says that in addition to starting the domain, we also make it persistent > at the same time. > > But if we do that, it would argue that 'virsh create --persistent > blah.xml' is nicer than 'virsh define --start blah.xml', at least in > that the former needs only 1 API call for new libvirt (but falls back to > 2 API calls when talking to older libvirt), while the latter always > needs 2 API calls. > > Or maybe it means we need to add virDomainDefineXMLFlags(). > > Anyone else want to throw some paint on the bikeshed on how best to make > the user experience nicer? While I think the virsh idea is fine, I don't want to see this done at the virDomainDefine API level, since it just duplicates functionality already present. Just have virsh make an API call to the existing create API. Daniel -- |: http://berrange.com -o- http://www.flickr.com/photos/dberrange/ :| |: http://libvirt.org -o- http://virt-manager.org :| |: http://autobuild.org -o- http://search.cpan.org/~danberr/ :| |: http://entangle-photo.org -o- http://live.gnome.org/gtk-vnc :| -- libvir-list mailing list libvir-list@xxxxxxxxxx https://www.redhat.com/mailman/listinfo/libvir-list