Re: [test-API PATCH 0/3] make clean function optional

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On 04/16/2012 02:20 PM, Osier Yang wrote:
On 2012年04月16日 14:11, Guannan Ren wrote:

The set of patches is to make the writing of clean function optional.
If a testcase which doesn't dirty the testing environment, then the
TESTCASE_clean function could be optional or omitted.

Good, this was one of the TODO thing in my mind.


Because loggers in python are static objects managed by the module itself. When you create one, it won't be removed until the shell quit. In test-API
there are two loggers which are configured with two handlers for each.
we need to find a way to destruct these two loggers in order no to affect
other application.  The idea is to clear the handlers of each logger in
destructor of CaseLog and EnvLog.

     def __del__(self):
         self.logger.handlers = []


rename some unclear function and variables.
for example: repos/domain/start.py

IIUC, you do 3 different things in these 3 patches, it will be good
to document them separately here for easy reviewing.

       get it, thanks.




domain ->  mod
start.py ->  case
start() ->  func


What does these mean?


       just a naming convention
If you see a variable like "mod_case_func", that refers to "damain:start:start"
       The second start is the function in start.py
       variable mod_case means "domain:start" that is the testcase file
       all of code will use the same naming convention.

       Guannan Ren

--
libvir-list mailing list
libvir-list@xxxxxxxxxx
https://www.redhat.com/mailman/listinfo/libvir-list



[Index of Archives]     [Virt Tools]     [Libvirt Users]     [Lib OS Info]     [Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Big List of Linux Books]     [Yosemite News]     [KDE Users]     [Fedora Tools]