On Fri, Jan 06, 2012 at 12:19:34PM +0400, Christophe Fergeau wrote: > Hey, > > On Fri, Dec 23, 2011 at 09:58:23PM +0200, Zeeshan Ali (Khattak) wrote: > > From: "Zeeshan Ali (Khattak)" <zeeshanak@xxxxxxxxx> > > > > Its just a set of synchronous and asynchronous wrappers around > > virDomainManagedSave. > > --- > > libvirt-gobject/libvirt-gobject-domain.c | 120 ++++++++++++++++++++++++++++++ > > libvirt-gobject/libvirt-gobject-domain.h | 11 +++ > > libvirt-gobject/libvirt-gobject.sym | 3 + > > 3 files changed, 134 insertions(+), 0 deletions(-) > > > > diff --git a/libvirt-gobject/libvirt-gobject-domain.c b/libvirt-gobject/libvirt-gobject-domain.c > > index e4963ed..8496257 100644 > > --- a/libvirt-gobject/libvirt-gobject-domain.c > > +++ b/libvirt-gobject/libvirt-gobject-domain.c > > @@ -708,3 +708,123 @@ gboolean gvir_domain_suspend (GVirDomain *dom, > > cleanup: > > return ret; > > } > > + > > +/** > > + * gvir_domain_saved_suspend: > > _saved_suspend is good for me even though it took me a while to get what it > means. Maybe _persistent_suspend would be better? Hopefully this won't turn > into some bikeshedding, but since we are not reusing the libvirt naming,I > feelt it was worth making an alternate suggestion :) I'd suggest just calling it 'gvir_domain_save' really. Daniel -- |: http://berrange.com -o- http://www.flickr.com/photos/dberrange/ :| |: http://libvirt.org -o- http://virt-manager.org :| |: http://autobuild.org -o- http://search.cpan.org/~danberr/ :| |: http://entangle-photo.org -o- http://live.gnome.org/gtk-vnc :| -- libvir-list mailing list libvir-list@xxxxxxxxxx https://www.redhat.com/mailman/listinfo/libvir-list