Re: [libvirt-glib 29/37] Add GVirConfigDeviceInput

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



just a comment about naming.

If we use prefix "Device" before devices class, I think it should be
done for the rest of the class for consistency.

> +void gvir_config_device_input_set_bus(GVirConfigDeviceInput *input,
> +                                      const char *bus)
> +{
> +    xmlNodePtr node;
> +
> +    node = gvir_config_object_get_xml_node(GVIR_CONFIG_OBJECT(input));
> +    if (node == NULL)
> +        return;
> +    xmlNewProp(node, (xmlChar*)"bus", (xmlChar*)bus);
> +}

The bus argument could be an enum too ("xen" (paravirtualized), "ps2" and "usb")

-- 
Marc-André Lureau

--
libvir-list mailing list
libvir-list@xxxxxxxxxx
https://www.redhat.com/mailman/listinfo/libvir-list



[Index of Archives]     [Virt Tools]     [Libvirt Users]     [Lib OS Info]     [Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Big List of Linux Books]     [Yosemite News]     [KDE Users]     [Fedora Tools]