On Thu, Jul 21, 2011 at 06:08:31PM +0200, Michal Privoznik wrote: > This series creates new API which adds flags to > virDomainDestroy. As mentioned here many times, it is > a bad luck all APIs don't have flags parameter. > > Parameter for this might be needed to select different > ways of destroying a domain. For example, qemu has 'quit' > command, which force it to flush internal caches a thus > preventing from data loss. Or vice versa - in cases > where we are doing hypervisor assisted destroy we might > want to send signals, because hypervisor is not responding. > > Currently, no new functionality is implemented, but > this paves the way for creating multiple ways of domain > destroying. Therefore, calling this new API is the same > as calling its predecessor. > > diff to v1: > -rename virDominDestroyWithFlags() to > virDominDestroyFlags() > -rename enum virDominDestroyFlags to > virDominDestroyFlagsValues > > Michal Privoznik (13): > destroy: Define new public API virDomainDestroyFlags > destroy: Wire up the remote protocol > destroy: Implement internal API for qemu driver > destroy: Implement internal API for ESX driver > destroy: Implement internal API for libxl driver > destroy: Implement internal API for lxc driver > destroy: Implement internal API for openvz driver > destroy: Implement internal API for phyp driver > destroy: Implement internal API for uml driver > destroy: Implement internal API for vbox driver > destroy: Implement internal API for vmware driver > destroy: Implement internal API for xen driver > destroy: Implement internal API for xenapi driver > > include/libvirt/libvirt.h.in | 7 +++++ > src/driver.h | 4 +++ > src/esx/esx_driver.c | 12 +++++++++- > src/libvirt.c | 52 ++++++++++++++++++++++++++++++++++++++++++ > src/libvirt_public.syms | 1 + > src/libxl/libxl_driver.c | 12 +++++++++- > src/lxc/lxc_driver.c | 23 +++++++++++++++++- > src/openvz/openvz_driver.c | 13 +++++++++- > src/phyp/phyp_driver.c | 12 +++++++++- > src/qemu/qemu_driver.c | 13 +++++++++- > src/remote/remote_driver.c | 1 + > src/remote/remote_protocol.x | 8 +++++- > src/remote_protocol-structs | 5 ++++ > src/uml/uml_driver.c | 14 ++++++++++- > src/vbox/vbox_tmpl.c | 14 ++++++++++- > src/vmware/vmware_driver.c | 12 +++++++++- > src/xen/xen_driver.c | 28 ++++++++++++++++++++++ > src/xen/xen_driver.h | 1 + > src/xen/xen_hypervisor.c | 24 +++++++++++++++++- > src/xen/xen_hypervisor.h | 3 ++ > src/xen/xen_inotify.c | 1 + > src/xen/xend_internal.c | 24 +++++++++++++++++- > src/xen/xm_internal.c | 1 + > src/xen/xs_internal.c | 1 + > src/xenapi/xenapi_driver.c | 22 ++++++++++++++++- > 25 files changed, 291 insertions(+), 17 deletions(-) ACK to the whole series Daniel -- |: http://berrange.com -o- http://www.flickr.com/photos/dberrange/ :| |: http://libvirt.org -o- http://virt-manager.org :| |: http://autobuild.org -o- http://search.cpan.org/~danberr/ :| |: http://entangle-photo.org -o- http://live.gnome.org/gtk-vnc :| -- libvir-list mailing list libvir-list@xxxxxxxxxx https://www.redhat.com/mailman/listinfo/libvir-list