On Thu, Mar 10, 2011 at 10:05:53 +0100, Jiri Denemark wrote: > This version 3 gets back to the second alternative for HMP passthrough > implementation provided in version 1. Changes made sinve that version 1 was > posted are: > - separate HMP passthrough infrastructure into a standalone patch > - use qemuMonitorHMPCommand* and qemuMonitorTextCommand* instead of just > qemuMonitorCommand* to make it obvious they deal with HMP/text monitor > - implement HMP fallback for {load,del}vm in addition to savevm > - escape snapshot name > > Jiri Denemark (5): > qemu: Setup infrastructure for HMP passthrough > qemu: Rename qemuMonitorCommand{,WithFd} as qemuMonitorHMP* > qemu: Rename qemuMonitorCommandWithHandler as qemuMonitorText* > qemu: Fallback to HMP for snapshot commands > qemu: Escape snapshot name passed to {save,load,del}vm > > src/qemu/qemu_monitor.c | 12 +++ > src/qemu/qemu_monitor.h | 8 ++- > src/qemu/qemu_monitor_json.c | 121 ++++++++++++++++++++++--------- > src/qemu/qemu_monitor_json.h | 5 ++ > src/qemu/qemu_monitor_text.c | 163 ++++++++++++++++++++++-------------------- > src/qemu/qemu_monitor_text.h | 5 ++ > 6 files changed, 200 insertions(+), 114 deletions(-) Thanks for the review, pushed. Jirka -- libvir-list mailing list libvir-list@xxxxxxxxxx https://www.redhat.com/mailman/listinfo/libvir-list