[PATCH v3 0/5] qemu: Support domain snapshots with current QMP

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



This version 3 gets back to the second alternative for HMP passthrough
implementation provided in version 1. Changes made sinve that version 1 was
posted are:
- separate HMP passthrough infrastructure into a standalone patch
- use qemuMonitorHMPCommand* and qemuMonitorTextCommand* instead of just
  qemuMonitorCommand* to make it obvious they deal with HMP/text monitor
- implement HMP fallback for {load,del}vm in addition to savevm
- escape snapshot name

Jiri Denemark (5):
  qemu: Setup infrastructure for HMP passthrough
  qemu: Rename qemuMonitorCommand{,WithFd} as qemuMonitorHMP*
  qemu: Rename qemuMonitorCommandWithHandler as qemuMonitorText*
  qemu: Fallback to HMP for snapshot commands
  qemu: Escape snapshot name passed to {save,load,del}vm

 src/qemu/qemu_monitor.c      |   12 +++
 src/qemu/qemu_monitor.h      |    8 ++-
 src/qemu/qemu_monitor_json.c |  121 ++++++++++++++++++++++---------
 src/qemu/qemu_monitor_json.h |    5 ++
 src/qemu/qemu_monitor_text.c |  163 ++++++++++++++++++++++--------------------
 src/qemu/qemu_monitor_text.h |    5 ++
 6 files changed, 200 insertions(+), 114 deletions(-)

-- 
1.7.4.1

--
libvir-list mailing list
libvir-list@xxxxxxxxxx
https://www.redhat.com/mailman/listinfo/libvir-list


[Index of Archives]     [Virt Tools]     [Libvirt Users]     [Lib OS Info]     [Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Big List of Linux Books]     [Yosemite News]     [KDE Users]     [Fedora Tools]