There are two main reasons behind this patchset: - we are getting very close to 64 flags which is the maximum we can use with unsigned long long - by using LL constants in enum we already violates C99 constraint that enum values have to fit into int Patches 3/7 and 5/7 are fully and 4/7 mostly mechanical. 6/7 and 7/7 need to be squashed into a single patch but are provided separately for easier review. Changes in version 2 are described in each patch separately. Jiri Denemark (7): util: Use unsigned long as a base type for virBitmap util: Add API for converting virBitmap into printable string qemu: Rename QEMUD_CMD_FLAG_* to QEMU_CAPS_* qemu: Use helper functions for handling cmd line capabilities qemu: Rename qemud\?CmdFlags to qemuCaps qemu: Switch over command line capabilities to virBitmap tests: Use virBitmap for qemu command line caps cfg.mk | 3 +- src/libvirt_private.syms | 1 + src/qemu/qemu_capabilities.c | 238 +++++++++----- src/qemu/qemu_capabilities.h | 152 +++++---- src/qemu/qemu_command.c | 392 +++++++++++----------- src/qemu/qemu_command.h | 30 +- src/qemu/qemu_driver.c | 48 ++-- src/qemu/qemu_hotplug.c | 162 +++++----- src/qemu/qemu_hotplug.h | 32 +- src/qemu/qemu_migration.c | 22 +- src/qemu/qemu_process.c | 29 +- src/util/bitmap.c | 51 +++- src/util/bitmap.h | 3 + tests/qemuargv2xmltest.c | 2 +- tests/qemuhelptest.c | 747 +++++++++++++++++++++--------------------- tests/qemuxml2argvtest.c | 474 +++++++++++++------------- 16 files changed, 1263 insertions(+), 1123 deletions(-) -- 1.7.4.1 -- libvir-list mailing list libvir-list@xxxxxxxxxx https://www.redhat.com/mailman/listinfo/libvir-list