On 02/09/2011 09:58 AM, Daniel P. Berrange wrote: > Move the qemudStartVMDaemon and qemudShutdownVMDaemon > methods into a separate file, renaming them to > qemuProcessStart, qemuProcessStop. All helper methods > called by these are also moved & renamed to match > > * src/Makefile.am: Add qemu_process.c/.h > * src/qemu/qemu_command.c: Add emuDomainAssignPCIAddresses s/ emu/ qemu/ > * src/qemu/qemu_command.h: Add VNC port min/max > * src/qemu/qemu_domain.c, src/qemu/qemu_domain.h: Add > domain event queue helpers > * src/qemu/qemu_driver.c, src/qemu/qemu_driver.h: Remove > all QEMU process startup/shutdown functions > * src/qemu/qemu_process.c, src/qemu/qemu_process.h: Add > all QEMU process startup/shutdown functions > --- > po/POTFILES.in | 1 + > src/Makefile.am | 1 + > src/qemu/qemu_command.c | 29 + > src/qemu/qemu_command.h | 5 + > src/qemu/qemu_domain.c | 56 + > src/qemu/qemu_domain.h | 11 + > src/qemu/qemu_driver.c | 3535 ++++++++--------------------------------------- > src/qemu/qemu_driver.h | 31 +- > src/qemu/qemu_process.c | 2417 ++++++++++++++++++++++++++++++++ > src/qemu/qemu_process.h | 52 + > 10 files changed, 3121 insertions(+), 3017 deletions(-) > create mode 100644 src/qemu/qemu_process.c > create mode 100644 src/qemu/qemu_process.h ACK; I reviewed an interdiff between this and your v1 [1], and you have correctly picked up all the changes that went in to qemu_driver.c since that posting, as well as resolved all my concerns from that post, except for the spelling nit in the commit message. [1] https://www.redhat.com/archives/libvir-list/2011-January/msg01255.html -- Eric Blake eblake@xxxxxxxxxx +1-801-349-2682 Libvirt virtualization library http://libvirt.org
Attachment:
signature.asc
Description: OpenPGP digital signature
-- libvir-list mailing list libvir-list@xxxxxxxxxx https://www.redhat.com/mailman/listinfo/libvir-list