I noticed that there is quite a bit of code duplication among the drivers that support domain events. This patch series is an attempt to consolidate the shared logic. v2: 2 patches were applied Addressed Eric's comments: NONNULL tagging Use bool for isDispatching Move libvirt_private.syms earlier Add NULL check in StateFree Cole Robinson (6): domain_event: Add virDomainEventState structure domain_event: Add common domain event queue/flush helpers qemu: Use virDomainEventState helpers lxc: Use virDomainEventState helpers test: Use virDomainEventState helpers remote: Use virDomainEventState helpers cfg.mk | 1 + src/conf/domain_event.c | 166 ++++++++++++++++++++++++++++++++++++++----- src/conf/domain_event.h | 69 +++++++++++++++---- src/libvirt_private.syms | 6 ++ src/lxc/lxc_conf.h | 6 +-- src/lxc/lxc_driver.c | 76 ++++++-------------- src/qemu/qemu_conf.h | 6 +-- src/qemu/qemu_driver.c | 80 +++++++-------------- src/remote/remote_driver.c | 162 ++++++++++++++++-------------------------- src/test/test_driver.c | 104 ++++++++------------------- 10 files changed, 353 insertions(+), 323 deletions(-) -- 1.7.3.3 -- libvir-list mailing list libvir-list@xxxxxxxxxx https://www.redhat.com/mailman/listinfo/libvir-list