ïThe idea was to stick to libvirt API documentation which contain a libvirt
part and a virError part. Types are used everywhere that's why they are at a
upper level (LibvirtBindings). In fact, libVirt and libvirtError are in the
LibvirtBindings, as they are classes. This is useful to clean the code and
not have all the code in one class... But I don't know what is better,
usually, in this kind of project, I'm used to separate things.
--------------------------------------------------
From: "Matthias Bolte" <matthias.bolte@xxxxxxxxxxxxxx>
Sent: Tuesday, October 19, 2010 5:43 PM
To: <arnaud.champion@xxxxxxxxxx>
Cc: "Justin Clift" <jclift@xxxxxxxxxx>; <libvir-list@xxxxxxxxxx>
Subject: Re: C# bindings (Was: First patch)
2010/10/18 <arnaud.champion@xxxxxxxxxx>:
The class library expose the "LibvirtBindings" namespace. This namespace
expose all needed types (enum, struct). It also expose 2 main classes :
"libVirt" and "libvirtError". The "libVirt" class expose all interfaces
of
the libvirt library to handle virtualized domains and "libvirtError"
class
expose all interfaces of the libvirt library to handle errors raised
while
using the library.
Is there a specific reason to use three different ways to capitalize
libvirt in the C# code?
LibvirtBindings
libVirt
libvirtError
I suggest you choose one form and stick with it, for example
LibvirtBindings
Libvirt
LibvirtError
Matthias
--
libvir-list mailing list
libvir-list@xxxxxxxxxx
https://www.redhat.com/mailman/listinfo/libvir-list