On Fri, Jan 31, 2025 at 10:20:23AM +0100, Peter Krempa wrote: > On Wed, Jan 08, 2025 at 19:42:45 +0000, Daniel P. Berrangé wrote: > > Currently the session daemon will try a managed save on all VMs, > > leaving them running if that fails. > > > > This limits the managed save just to persistent VMs, as there will > > usually not be any way to restore transient VMs later. > > > > It also enables graceful shutdown and then forced poweroff, should > > save fail for some reason. > > > > These new defaults can be overridden in the config file if needed. > > > > Signed-off-by: Daniel P. Berrangé <berrange@xxxxxxxxxx> > > --- > > src/qemu/libvirtd_qemu.aug | 2 +- > > src/qemu/qemu.conf.in | 14 ++++++++------ > > src/qemu/qemu_conf.c | 6 +++--- > > src/qemu/test_libvirtd_qemu.aug.in | 6 +++--- > > 4 files changed, 15 insertions(+), 13 deletions(-) > > > > diff --git a/src/qemu/libvirtd_qemu.aug b/src/qemu/libvirtd_qemu.aug > > index e465a231fc..605604a01a 100644 > > --- a/src/qemu/libvirtd_qemu.aug > > +++ b/src/qemu/libvirtd_qemu.aug > > @@ -100,7 +100,7 @@ module Libvirtd_qemu = > > | int_entry "auto_start_delay" > > | str_entry "auto_shutdown_try_save" > > | str_entry "auto_shutdown_try_shutdown" > > - | str_entry "auto_shutdown_powerdown" > > + | str_entry "auto_shutdown_poweroff" > > > > let process_entry = str_entry "hugetlbfs_mount" > > | str_entry "bridge_helper" > > This hunk belongs to previous patch. > > > diff --git a/src/qemu/qemu.conf.in b/src/qemu/qemu.conf.in > > index d8890c4c32..82eae2eecd 100644 > > --- a/src/qemu/qemu.conf.in > > +++ b/src/qemu/qemu.conf.in > > @@ -647,33 +647,35 @@ > > # * "transient" - only try to save transient running VMs > > # * "all" - try to save all running VMs > > # > > -# Defaults to "all" for session daemons and "none" > > +# Defaults to "persistent" for session daemons and "none" > > # for system daemons > > # > > # If 'libvirt-guests.service' is enabled, then this must be > > # set to 'none' for system daemons to avoid dueling actions > > -#auto_shutdown_try_save = "all" > > +#auto_shutdown_try_save = "persistent" > > As noted 'all' doesn't make sense for 'save' operation so I'd call that > a bugfix. Perhaps even worhty of a separate patch. This can be naturally fixed at the point where we make this configurable 2 patches earlier. With regards, Daniel -- |: https://berrange.com -o- https://www.flickr.com/photos/dberrange :| |: https://libvirt.org -o- https://fstop138.berrange.com :| |: https://entangle-photo.org -o- https://www.instagram.com/dberrange :|