Re: [PATCH 00/10] Enabling logging for ch guests

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 





On 12/20/2024 9:54 AM, Michal Prívozník wrote:
On 12/19/24 15:45, Praveen K Paladugu wrote:
LogContext management is now moved from Qemu driver to hypervisor. After
migrating Qemu to use domain_logcontext, I extended ch driver to use also use
domain_logcontext to capture early boot failures within domain specific log
files.

Changes in V2:
* refactored the patches to ensure all of them build.

Praveen K Paladugu (10):
   hypervisor: copy qemu log context mgmt to hypervisor
   hypervisor: rename reference to qemu in domain_logcontext
   hypervisor: drop qemu specific args in domainLogContextNew
   hypervisor: Build domain_logcontext
   libvirt_private: export symbols from domain_logcontext
   qemu: Modify qemu driver to use domainLogContext
   qemu: delete qemu_logcontext files
   ch: Enable logging for ch domains
   ch: move curl_data and curl_callback definitions
   ch: Enable logging curl responses from ch

  po/POTFILES                                   |  2 +-
  src/ch/ch_conf.h                              |  2 +
  src/ch/ch_monitor.c                           | 84 ++++++++++++-------
  src/ch/ch_monitor.h                           |  6 +-
  src/ch/ch_process.c                           | 36 ++++++--
  .../domain_logcontext.c}                      | 78 +++++++++--------
  src/hypervisor/domain_logcontext.h            | 45 ++++++++++
  src/hypervisor/meson.build                    |  1 +
  src/libvirt_private.syms                      |  6 ++
  src/qemu/meson.build                          |  1 -
  src/qemu/qemu_domain.c                        | 28 +++----
  src/qemu/qemu_domain.h                        | 12 +--
  src/qemu/qemu_logcontext.h                    | 41 ---------
  src/qemu/qemu_nbdkit.c                        | 12 ++-
  src/qemu/qemu_process.c                       | 45 +++++-----
  15 files changed, 235 insertions(+), 164 deletions(-)
  rename src/{qemu/qemu_logcontext.c => hypervisor/domain_logcontext.c} (79%)
  create mode 100644 src/hypervisor/domain_logcontext.h
  delete mode 100644 src/qemu/qemu_logcontext.h


While this now compiles after each commit, it's also unnecessary
verbose. I mean - I'm squashing commits 1-7 into one as it'll enable git
see that qemu_logcontext.c was actually moved and renamed. It can save
us in the future.

Reviewed-by: Michal Privoznik <mprivozn@xxxxxxxxxx>

and merged.

Michal

Sounds good Michal.

Thanks for merging them.

--
Regards,
Praveen K Paladugu




[Index of Archives]     [Virt Tools]     [Libvirt Users]     [Lib OS Info]     [Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Big List of Linux Books]     [Yosemite News]     [KDE Users]     [Fedora Tools]

  Powered by Linux