On Fri, 2010-04-02 at 21:46 -0400, Chris Lalancette wrote: <snip> > @@ -8288,6 +8731,14 @@ static const vshCmdDef commands[] = { > {"vcpupin", cmdVcpupin, opts_vcpupin, info_vcpupin}, > {"version", cmdVersion, NULL, info_version}, > {"vncdisplay", cmdVNCDisplay, opts_vncdisplay, info_vncdisplay}, > + > + {"snapshot-create", cmdSnapshotCreate, opts_snapshot_create, info_snapshot_create}, > + {"snapshot-current", cmdSnapshotCurrent, opts_snapshot_current, info_snapshot_current}, > + {"snapshot-delete", cmdSnapshotDelete, opts_snapshot_delete, info_snapshot_delete}, > + {"snapshot-dumpxml", cmdSnapshotDumpXML, opts_snapshot_dumpxml, info_snapshot_dumpxml}, > + {"snapshot-list", cmdSnapshotList, opts_snapshot_list, info_snapshot_list}, > + {"revert-to-snapshot", cmdDomainRevertToSnapshot, opts_revert_to_snapshot, info_revert_to_snapshot}, > + > {NULL, NULL, NULL, NULL} > }; All the new virsh commands for snapshot management follow the convention of snapshot- prefix (like similar pool-, vol-, net- command prefixes) except for revert-to-snapshot. From a virsh usability perspective, would it make sense to rename this command snapshot-revert? I appreciate that does not capture what the command does as well as revert-to-snapshot but I think this may be a reasonable trade-off for usability and users finding the command easily. Thanks, Paul -- libvir-list mailing list libvir-list@xxxxxxxxxx https://www.redhat.com/mailman/listinfo/libvir-list