[PATCH v2 00/10] qemu: support renaming domains with snapshots/checkpoints

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



This is basically just rebase of [1] as it was not get any attention at that
time.

[1] [PATCH 0/8] qemu: support renaming domains with snapshots/checkpoints
https://www.redhat.com/archives/libvir-list/2020-March/msg00018.html

Nikolay Shirokovskiy (10):
  qemu: qemuDomainRenameCallback: fix sending false undefined event
  qemu: rename: send events only on success
  qemu: rename: return instead of goto if no cleanup required
  qemu: remove duplicate code for removing remnant files
  qemu: rename: support renaming snapshots directory
  qemu: rename: support renaming checkpoints directory
  qemu: update name on reverting from snapshot
  qemu: rename: remove snapshot/checkpoint restriction
  qemu: qemuDomainDefineXMLFlags: move cleanup logic to cleanup section
  qemu: remove possible garbage left from previous rename/undefine

 src/qemu/qemu_checkpoint.c |   2 +-
 src/qemu/qemu_checkpoint.h |   6 ++
 src/qemu/qemu_domain.c     |  43 ++++++++++++
 src/qemu/qemu_domain.h     |   5 ++
 src/qemu/qemu_driver.c     | 158 ++++++++++++++++++++++++++-------------------
 src/qemu/qemu_migration.c  |   3 +
 src/qemu/qemu_snapshot.c   |  10 +++
 7 files changed, 160 insertions(+), 67 deletions(-)

--
1.8.3.1




[Index of Archives]     [Virt Tools]     [Libvirt Users]     [Lib OS Info]     [Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Big List of Linux Books]     [Yosemite News]     [KDE Users]     [Fedora Tools]

  Powered by Linux