2010/2/1 Daniel P. Berrange <berrange@xxxxxxxxxx>: > The current way of assigning names to the host network backend and > NIC device in QEMU was over complicated, by varying naming scheme > based on the NIC model and backend type. This simplifies the naming > to simply be 'net0' and 'hostnet0', allowing code to easily determine > the host network name and vlan based off the primary device alias > name 'net0'. This in turn allows removal of alot of QEMU specific > code from the XML parser, and makes it easier to assign new unique > names for NICs that are hotplugged > > * src/conf/domain_conf.c, src/conf/domain_conf.h: Remove hostnet_name > and vlan fields from virNetworkDefPtr > * src/qemu/qemu_conf.c, src/qemu/qemu_conf.h, src/qemu/qemu_driver.c: > Use a single network alias naming scheme regardless of NIC type > or backend type. Determine VLANs from the alias name. > * tests/qemuxml2argvdata/qemuxml2argv-net-eth-names.args, > tests/qemuxml2argvdata/qemuxml2argv-net-virtio-device.args, > tests/qemuxml2argvdata/qemuxml2argv-net-virtio-netdev.args: Update > for new simpler naming scheme > --- ACK Matthias -- libvir-list mailing list libvir-list@xxxxxxxxxx https://www.redhat.com/mailman/listinfo/libvir-list