[libvirt PATCH 5/5] qemu: reuse convenience variable introduced in a00b97f27672b3

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Since we have the result of a compound condition named now we can use it
to simplify another complex condition to make it more readable.

Signed-off-by: Pavel Mores <pmores@xxxxxxxxxx>
---
 src/network/bridge_driver.c | 3 +--
 1 file changed, 1 insertion(+), 2 deletions(-)

diff --git a/src/network/bridge_driver.c b/src/network/bridge_driver.c
index 513ae59e68..584c78cadb 100644
--- a/src/network/bridge_driver.c
+++ b/src/network/bridge_driver.c
@@ -5081,8 +5081,7 @@ networkCheckBandwidth(virNetworkObjPtr obj,
         return -1;
     }
 
-    if (ifaceBand && ifaceBand->in && ifaceBand->in->floor &&
-        !(netBand && netBand->in)) {
+    if (floorRequested && !(netBand && netBand->in)) {
         virReportError(VIR_ERR_OPERATION_UNSUPPORTED,
                        _("Invalid use of 'floor' on interface with MAC "
                          "address %s - network '%s' has no inbound QoS set"),
-- 
2.24.1





[Index of Archives]     [Virt Tools]     [Libvirt Users]     [Lib OS Info]     [Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Big List of Linux Books]     [Yosemite News]     [KDE Users]     [Fedora Tools]

  Powered by Linux