On Wed, Dec 23, 2009 at 04:28:34AM +0100, Matthias Bolte wrote: > Alter the offending variable names to fix this. > --- > src/esx/esx_vi.h | 2 +- > src/esx/esx_vi_types.h | 4 ++-- > src/util/json.c | 14 +++++++------- > 3 files changed, 10 insertions(+), 10 deletions(-) > > diff --git a/src/esx/esx_vi.h b/src/esx/esx_vi.h > index 840a3c3..f76689c 100644 > --- a/src/esx/esx_vi.h > +++ b/src/esx/esx_vi.h > @@ -138,7 +138,7 @@ struct _esxVI_Enumeration { > > int esxVI_Enumeration_CastFromAnyType(virConnectPtr conn, > const esxVI_Enumeration *enumeration, > - esxVI_AnyType *anyType, int *boolean); > + esxVI_AnyType *anyType, int *value); > int esxVI_Enumeration_Serialize(virConnectPtr conn, > const esxVI_Enumeration *enumeration, > int value, const char *element, > diff --git a/src/esx/esx_vi_types.h b/src/esx/esx_vi_types.h > index 4183324..77f712e 100644 > --- a/src/esx/esx_vi_types.h > +++ b/src/esx/esx_vi_types.h > @@ -131,11 +131,11 @@ enum _esxVI_Boolean { > esxVI_Boolean_False, > }; > > -int esxVI_Boolean_Serialize(virConnectPtr conn, esxVI_Boolean boolean, > +int esxVI_Boolean_Serialize(virConnectPtr conn, esxVI_Boolean boolean_, > const char *element, virBufferPtr output, > esxVI_Boolean required); > int esxVI_Boolean_Deserialize(virConnectPtr conn, xmlNodePtr node, > - esxVI_Boolean *boolean); > + esxVI_Boolean *boolean_); > > > > diff --git a/src/util/json.c b/src/util/json.c > index 35f6e52..4b3e629 100644 > --- a/src/util/json.c > +++ b/src/util/json.c > @@ -201,7 +201,7 @@ virJSONValuePtr virJSONValueNewNumberDouble(double data) > } > > > -virJSONValuePtr virJSONValueNewBoolean(int boolean) > +virJSONValuePtr virJSONValueNewBoolean(int boolean_) > { > virJSONValuePtr val; > > @@ -209,7 +209,7 @@ virJSONValuePtr virJSONValueNewBoolean(int boolean) > return NULL; > > val->type = VIR_JSON_TYPE_BOOLEAN; > - val->data.boolean = boolean; > + val->data.boolean = boolean_; > > return val; > } > @@ -350,9 +350,9 @@ int virJSONValueObjectAppendNumberDouble(virJSONValuePtr object, const char *key > return 0; > } > > -int virJSONValueObjectAppendBoolean(virJSONValuePtr object, const char *key, int boolean) > +int virJSONValueObjectAppendBoolean(virJSONValuePtr object, const char *key, int boolean_) > { > - virJSONValuePtr jvalue = virJSONValueNewBoolean(boolean); > + virJSONValuePtr jvalue = virJSONValueNewBoolean(boolean_); > if (!jvalue) > return -1; > if (virJSONValueObjectAppend(object, key, jvalue) < 0) { > @@ -688,12 +688,12 @@ static int virJSONParserHandleNull(void * ctx) > return 1; > } > > -static int virJSONParserHandleBoolean(void * ctx, int boolean) > +static int virJSONParserHandleBoolean(void * ctx, int boolean_) > { > virJSONParserPtr parser = ctx; > - virJSONValuePtr value = virJSONValueNewBoolean(boolean); > + virJSONValuePtr value = virJSONValueNewBoolean(boolean_); > > - VIR_DEBUG("parser=%p boolean=%d", parser, boolean); > + VIR_DEBUG("parser=%p boolean=%d", parser, boolean_); > > if (!value) > return 0; ACK, though I find boolean_ a bit disgusting what about bool_arg if you want to keep this a generic name ? Daniel -- Daniel Veillard | libxml Gnome XML XSLT toolkit http://xmlsoft.org/ daniel@xxxxxxxxxxxx | Rpmfind RPM search engine http://rpmfind.net/ http://veillard.com/ | virtualization library http://libvirt.org/ -- Libvir-list mailing list Libvir-list@xxxxxxxxxx https://www.redhat.com/mailman/listinfo/libvir-list