Re: [PATCH v2 10/12] esx: split scsilunToStorageVol helper

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On 11/15/19 7:40 AM, Pino Toscano wrote:
> Move the creation of a virStorageVolPtr object from the esxVI_ScsiLun
> object of a SCSI lun out of esxStorageVolLookupByName and
> esxStorageVolLookupByPath in an own helper. This way it can be used
> also in other functions.
> 
> Signed-off-by: Pino Toscano <ptoscano@xxxxxxxxxx>
> ---
>  src/esx/esx_storage_backend_iscsi.c | 60 +++++++++++++++--------------
>  1 file changed, 31 insertions(+), 29 deletions(-)
> 
> diff --git a/src/esx/esx_storage_backend_iscsi.c b/src/esx/esx_storage_backend_iscsi.c
> index 4f5d8e5e24..34760a837e 100644
> --- a/src/esx/esx_storage_backend_iscsi.c
> +++ b/src/esx/esx_storage_backend_iscsi.c
> @@ -440,6 +440,35 @@ esxStoragePoolListVolumes(virStoragePoolPtr pool, char **const names,
>  
>  
>  
> +static virStorageVolPtr
> +scsilunToStorageVol(virConnectPtr conn, esxVI_ScsiLun *scsiLun,
> +                    const char *pool)

I think this should be named 'scsiLunXXX' to be consistent with
capitalization used elsewhere

Reviewed-by: Cole Robinson <crobinso@xxxxxxxxxx>

- Cole

--
libvir-list mailing list
libvir-list@xxxxxxxxxx
https://www.redhat.com/mailman/listinfo/libvir-list




[Index of Archives]     [Virt Tools]     [Libvirt Users]     [Lib OS Info]     [Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Big List of Linux Books]     [Yosemite News]     [KDE Users]     [Fedora Tools]

  Powered by Linux