On Wed, Jul 10, 2019 at 17:44:31 +0200, Ilias Stamatis wrote: > The qemuDomainParseBlkioDeviceStr and lxcDomainParseBlkioDeviceSts > functions residing in the QEMU and LXC drivers respectively are > completely identical. > > By moving the code to src/conf we avoid code duplication and we make the > function available to other drivers that might need to call it such as > the test driver. > > Signed-off-by: Ilias Stamatis <stamatis.iliass@xxxxxxxxx> > --- > src/conf/domain_conf.c | 115 +++++++++++++++++++++++++++++++++++ > src/conf/domain_conf.h | 6 ++ > src/libvirt_private.syms | 1 + > src/lxc/lxc_driver.c | 112 +--------------------------------- > src/qemu/qemu_driver.c | 126 +++------------------------------------ > 5 files changed, 132 insertions(+), 228 deletions(-) > > diff --git a/src/conf/domain_conf.c b/src/conf/domain_conf.c > index 3323c9a5b1..e10390189c 100644 > --- a/src/conf/domain_conf.c > +++ b/src/conf/domain_conf.c > @@ -30219,6 +30219,121 @@ virDomainDefGetShortName(const virDomainDef *def) > > #undef VIR_DOMAIN_SHORT_NAME_MAX > > + > +/* blkioDeviceStr in the form of /device/path,weight,/device/path,weight > + * for example, /dev/disk/by-path/pci-0000:00:1f.2-scsi-0:0:0:0,800 > + */ > +int > +virDomainParseBlkioDeviceStr(char *blkioDeviceStr, The domain_conf.c module is meant to collect stuff regarding the XML parser and configuration-related methods. This is a worker method which does not have to do anything with config. Please find a proper place in src/util/ for it.
Attachment:
signature.asc
Description: PGP signature
-- libvir-list mailing list libvir-list@xxxxxxxxxx https://www.redhat.com/mailman/listinfo/libvir-list