Re: [PATCH 14/23] qemu_conf: split out virQEMUDriverConfigLoadProcessEntry

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 




On 1/15/19 8:23 AM, Ján Tomko wrote:
> Split out parts of the config parsing code to make
> the parent function easier to read.
> 
> Signed-off-by: Ján Tomko <jtomko@xxxxxxxxxx>
> ---
>  src/qemu/qemu_conf.c | 162 ++++++++++++++++++++++++-------------------
>  1 file changed, 90 insertions(+), 72 deletions(-)
> 

I was too quick with the send push...

[...]

>  static int
>  virQEMUDriverConfigLoadDeviceEntry(virQEMUDriverConfigPtr cfg,
>                                     virConfPtr conf)
> @@ -722,8 +811,6 @@ int virQEMUDriverConfigLoadFile(virQEMUDriverConfigPtr cfg,
>      virConfPtr conf = NULL;
>      int ret = -1;
>      int rv;
> -    size_t i;
> -    char *stdioHandler = NULL;
>      char **hugetlbfs = NULL;

This is now unused and don't forget the StringListFree at the bottom.

>      char *corestr = NULL;
>  
> @@ -894,79 +981,10 @@ int virQEMUDriverConfigLoadFile(virQEMUDriverConfigPtr cfg,
>          goto cleanup;
>      if (virConfGetValueBool(conf, "auto_start_bypass_cache", &cfg->autoStartBypassCache) < 0)
>          goto cleanup;
> -
> -    if (virConfGetValueStringList(conf, "hugetlbfs_mount", true,
> -                                  &hugetlbfs) < 0)
> -        goto cleanup;
> -    if (hugetlbfs) {
> -        /* There already might be something autodetected. Avoid leaking it. */
> -        while (cfg->nhugetlbfs) {
> -            cfg->nhugetlbfs--;
> -            VIR_FREE(cfg->hugetlbfs[cfg->nhugetlbfs].mnt_dir);
> -        }
> -        VIR_FREE(cfg->hugetlbfs);
> -
> -        cfg->nhugetlbfs = virStringListLength((const char *const *)hugetlbfs);
> -        if (hugetlbfs[0] &&
> -            VIR_ALLOC_N(cfg->hugetlbfs, cfg->nhugetlbfs) < 0)
> -            goto cleanup;
> -
> -        for (i = 0; hugetlbfs[i] != NULL; i++) {
> -            if (virQEMUDriverConfigHugeTLBFSInit(&cfg->hugetlbfs[i],
> -                                                 hugetlbfs[i], i != 0) < 0)
> -                goto cleanup;
> -        }
> -    }
> -
> -    if (virConfGetValueString(conf, "bridge_helper", &cfg->bridgeHelperName) < 0)
> -        goto cleanup;
> -
> -    if (virConfGetValueString(conf, "pr_helper", &cfg->prHelperName) < 0)
>          goto cleanup;

This makes a double "goto cleanup;" which you fix in the next patch, but
causes this patch to fail to compile...

With all that this patch is good.

John

[...]

--
libvir-list mailing list
libvir-list@xxxxxxxxxx
https://www.redhat.com/mailman/listinfo/libvir-list




[Index of Archives]     [Virt Tools]     [Libvirt Users]     [Lib OS Info]     [Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Big List of Linux Books]     [Yosemite News]     [KDE Users]     [Fedora Tools]

  Powered by Linux