On Tue, 2018-08-21 at 12:12 +0200, Michal Privoznik wrote: [...] > if (def->deviceType == VIR_DOMAIN_CHR_DEVICE_TYPE_CHANNEL && > - def->targetType == VIR_DOMAIN_CHR_CHANNEL_TARGET_TYPE_GUESTFWD) { > - VIR_DEBUG("Ignoring device address for gustfwd channel"); > - } else if (virDomainDeviceInfoParseXML(xmlopt, node, > - &def->info, flags) < 0) { > - goto error; > - } > - > + def->targetType == VIR_DOMAIN_CHR_CHANNEL_TARGET_TYPE_GUESTFWD) > + virDomainDeviceInfoClearAddress(&def->info); Our style guidelines require curly braces around the if body in this case - which is great, because it means your diff can be smaller and more readable! :) With that fixed Reviewed-by: Andrea Bolognani <abologna@xxxxxxxxxx> -- Andrea Bolognani / Red Hat / Virtualization -- libvir-list mailing list libvir-list@xxxxxxxxxx https://www.redhat.com/mailman/listinfo/libvir-list