[PATCH 00/10] Some CAT cleanups

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Just so we have something before more code gets in, this makes future changes
more straight-forward.

Martin Kletzander (10):
  util: Rename resctrl to alloc if it is virResctrlAllocPtr
  util: Fix typo in error message %ud -> %u
  util: Introduce virFileFlock
  util: Avoid needless preprocessor conditionals in virresctrl
  util: Use virFileFlock() in virresctrl
  util: Reorder parts of virresctrl
  util: Initialize virResctrlInfo struct right away
  Move virCacheKernel enum implemetation from conf/ to util/
  util: Remove cbm_mask from virResctrlInfoPerType
  Move host cache handling from conf/ to util/

 src/conf/capabilities.c   | 403 ++++++-------------
 src/conf/capabilities.h   |  21 +-
 src/libvirt_private.syms  |   8 +-
 src/qemu/qemu_process.c   |  26 +-
 src/util/virfile.c        |  40 ++
 src/util/virfile.h        |   2 +
 src/util/virresctrl.c     | 823 +++++++++++++++++++++++++-------------
 src/util/virresctrl.h     |  64 +--
 src/util/virresctrlpriv.h |   6 +-
 tests/virresctrltest.c    |  18 +-
 10 files changed, 763 insertions(+), 648 deletions(-)

-- 
2.17.1

--
libvir-list mailing list
libvir-list@xxxxxxxxxx
https://www.redhat.com/mailman/listinfo/libvir-list



[Index of Archives]     [Virt Tools]     [Libvirt Users]     [Lib OS Info]     [Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Big List of Linux Books]     [Yosemite News]     [KDE Users]     [Fedora Tools]

  Powered by Linux