... > > > > typedef enum { > > + VIR_DOMAIN_LAUNCH_SECURITY_NONE, > > + VIR_DOMAIN_LAUNCH_SECURITY_SEV, > > + > > + VIR_DOMAIN_LAUNCH_SECURITY_LAST, > > +} virDomainLaunchSecurity; > > + > > +typedef struct _virDomainSevDef virDomainSevDef; > > +typedef virDomainSevDef *virDomainSevDefPtr; > > + > > +struct _virDomainSevDef { > int sectype; /* enum virDomainLaunchSecurity */ > > John Good point, although, wrong place IMHO, since the other fields are specific to SEV. We can keep the struct (maybe rename it a bit), but we should go with something generic like virDomainLaunchSecurityDef, and then do... struct _virDomainLaunchSecurityDef { int sectype; /* enum virDomainLaunchSecurityType */ union { virDomainSevDefPtr sev; } } ..kinda thing... Erik -- libvir-list mailing list libvir-list@xxxxxxxxxx https://www.redhat.com/mailman/listinfo/libvir-list