Re: [PATCH v3] qemu: rename migration APIs to include Src or Dst in their name

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 




On 02/19/2018 06:46 AM, Daniel P. Berrangé wrote:
> It is very difficult while reading the migration code trying to
> understand whether a particular function is being called on the src side
> or the dst side, or either. Putting "Src" or "Dst" in the method names will
> make this much more obvious. "Any" is used in a few helpers which can be
> called from both sides.
> 
> Signed-off-by: Daniel P. Berrangé <berrange@xxxxxxxxxx>
> ---
> 
> Changed in v3:
> 
>  - Made most naming suggestions from John.
> 
>  src/qemu/qemu_driver.c    |  194 +++----
>  src/qemu/qemu_migration.c | 1378 +++++++++++++++++++++++----------------------
>  src/qemu/qemu_migration.h |  264 +++++----
>  src/qemu/qemu_process.c   |   20 +-
>  tests/qemuxml2argvtest.c  |    4 +-
>  5 files changed, 940 insertions(+), 920 deletions(-)
> 

Reviewed-by: John Ferlan <jferlan@xxxxxxxxxx>

John

--
libvir-list mailing list
libvir-list@xxxxxxxxxx
https://www.redhat.com/mailman/listinfo/libvir-list




[Index of Archives]     [Virt Tools]     [Libvirt Users]     [Lib OS Info]     [Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Big List of Linux Books]     [Yosemite News]     [KDE Users]     [Fedora Tools]

  Powered by Linux