'file.password-secret' and 'file.debug' were improperly added to a random place when formatting -drive. This would not play well when the same attributes should be formatted via the JSON generator. Clean up the mess. Peter Krempa (6): qemu: command: Inject password-secret only when not using JSON props util: storage: Add fields for debug options for disk drivers qemu: block: Add support for formatting gluster debug level via JSON qemu: hotplug: Rename qemuDomainPrepareDisk to qemuHotplugPrepareDiskAccess qemu: domain: Unify disk source prepare steps qemu: command: Properly format disk 'debug' attribute src/qemu/qemu_block.c | 17 +++++++++++++++-- src/qemu/qemu_command.c | 34 ++++++++++------------------------ src/qemu/qemu_command.h | 1 - src/qemu/qemu_domain.c | 27 +++++++++++++++++++++++++-- src/qemu/qemu_domain.h | 16 ++++++---------- src/qemu/qemu_hotplug.c | 29 +++++++++++++---------------- src/qemu/qemu_process.c | 5 +---- src/util/virstoragefile.c | 2 ++ src/util/virstoragefile.h | 3 +++ 9 files changed, 75 insertions(+), 59 deletions(-) -- 2.14.3 -- libvir-list mailing list libvir-list@xxxxxxxxxx https://www.redhat.com/mailman/listinfo/libvir-list