On Wed, 2017-11-15 at 12:50 +0100, Andrea Bolognani wrote: > @@ -10249,6 +10249,15 @@ qemuBuildSerialChrDeviceStr(char **deviceStr, > } > break; > > + case VIR_DOMAIN_CHR_SERIAL_TARGET_TYPE_SCLP: > + case VIR_DOMAIN_CHR_SERIAL_TARGET_TYPE_SCLPLM: > + if (!virQEMUCapsGet(qemuCaps, QEMU_CAPS_SCLP_S390)) { > + virReportError(VIR_ERR_CONFIG_UNSUPPORTED, "%s", > + _("sclp/sclplm console requires QEMU to support s390-sclp")); > + return -1; > + } > + break; It's existing code, but a single capability should really not be used for both devices. QEMU_CAPS_SCLP_S390 is set whenever sclpconsole is available, so it should be renamed to QEMU_CAPS_DEVICE_SCLPCONSOLE and a new QEMU_CAPS_DEVICE_SCLPLMCONSOLE should be introduced to signal the availability of sclplmconsole separately. With that fixed, and assuming the series gets ACKed up until here, Reviewed-by: Andrea Bolognani <abologna@xxxxxxxxxx> -- Andrea Bolognani / Red Hat / Virtualization -- libvir-list mailing list libvir-list@xxxxxxxxxx https://www.redhat.com/mailman/listinfo/libvir-list