The last of the storage pool object adjustments. The first patch is a followup from last series to alter the prototype for two functions to be "const char *". The next 17 patches make all the adjustments necessary to move the two structures into virstoragepoolobj.c The last patch is listed merely for completeness of using obj instead of pool, but I really don't care if it's not accepted. Still I present it to be "more complete" - there could be more just like it for the various storage_backend_*.c modules, but none are necessary "churn". Since it was written and in my branch, I just kept/posted it too. John Ferlan (19): conf: Fix prototype/definition for virStoragePoolObj get functions storage: Use virStoragePoolObjGetDef accessor for driver test: Rename @vol to @volDef in testOpenVolumesForPool test: Create local virStoragePoolObjPtr VolLookup APIs test: Use virStoragePoolObjGetDef accessor storage: Use virStoragePoolObjGetDef accessor for storage_util storage: Use virStoragePoolObjGetDef accessor for Disk backend storage: Use virStoragePoolObjGetDef accessor for Logical backend storage: Use virStoragePoolObjGetDef accessor for Sheepdog backend storage: Use virStoragePoolObjGetDef accessor for FS backend storage: Use virStoragePoolObjGetDef accessor for Gluster backend storage: Use virStoragePoolObjGetDef accessor for iSCSI backend storage: Use virStoragePoolObjGetDef accessor for MPATH backend storage: Use virStoragePoolObjGetDef accessor for RBD backend storage: Use virStoragePoolObjGetDef accessor for SCSI backend storage: Use virStoragePoolObjGetDef accessor for VSTORAGE backend storage: Use virStoragePoolObjGetDef accessor for ZFS backend storage: Privatize virStoragePoolObj and virStorageVolDefList storage: Change storage_util to use obj instead of pool src/conf/storage_conf.h | 4 - src/conf/virstorageobj.c | 24 +- src/conf/virstorageobj.h | 19 +- src/storage/storage_backend_disk.c | 98 ++++---- src/storage/storage_backend_fs.c | 90 ++++---- src/storage/storage_backend_gluster.c | 20 +- src/storage/storage_backend_iscsi.c | 41 ++-- src/storage/storage_backend_logical.c | 63 ++--- src/storage/storage_backend_mpath.c | 8 +- src/storage/storage_backend_rbd.c | 64 ++--- src/storage/storage_backend_scsi.c | 30 ++- src/storage/storage_backend_sheepdog.c | 23 +- src/storage/storage_backend_vstorage.c | 31 +-- src/storage/storage_backend_zfs.c | 39 ++-- src/storage/storage_driver.c | 411 +++++++++++++++++++-------------- src/storage/storage_util.c | 200 ++++++++-------- src/storage/storage_util.h | 30 +-- src/test/test_driver.c | 203 ++++++++-------- 18 files changed, 777 insertions(+), 621 deletions(-) -- 2.13.5 -- libvir-list mailing list libvir-list@xxxxxxxxxx https://www.redhat.com/mailman/listinfo/libvir-list