On 07/26/2017 05:05 PM, John Ferlan wrote: > v1: https://www.redhat.com/archives/libvir-list/2017-May/msg00701.html > (but reviewed much more recently) > > NOTE from v1: > Patches 1-3 already pushed > > Former patch 4: > * Patch 1 (NEW) - splits out the formatting change in bridge_driver.h > * Patch 2 - Remainder of the change for consistent naming > NB: Without the split, there was a R-B, but I didn't push so that the > split could be "seen". > > Former patch 5: > * Patch 3 (NEW) - from review create virMacMapFileName in src/util/virmacmap.c > * Patch 4 - Remainder of the previous change w/ adjusted name of course > * Patch 5 (NEW) - from review, alter virNetworkObjUnrefMacMap > > Former patch 6: > * Patch 6 - No change > > Former patch 7: > * Patch 7 (NEW) - Split out the @class_id to @classIdMap change > * Patch 8 - Remainder of previous change > > Former patch 8: > * Patch 9 - No change > > Former patch 9: > * Patch 10 - Make suggested naming adjustments > Add/use virNetworkObjSetDef API > > Former patch 10: > * Patch 11 - Move code back to driver, just have accessors for @autostart > > Former patch 11: > * Patch 12 - No change > > Former patch 12: > * Patch 13 - Use virNetworkObjIsPersistent in networkSetAutostart > > Former patch 13: > * Patch 14 - No change > > Former patch 14: > * Patch 15 - Just have the virNetworkObjNew lock the object now and make > use of that with using virNetworkObjEndAPI in networkxml2conftest > NB: Since we'll have a refcnt=1 and lock=true after New the > EndAPI is proper > * Patch 16 (NEW) - Just move the virObjectRef - makes it clearer why it's > being ref'd > Former patch 15: > * Patch 17 (NEW) - Split out the rename of @nnames to @maxnames and explain > the reason better > * Patch 18 (NEW) - Split out the rename of @filter to @aclnames and explain > the reason better > * Patch 19 - The remainder of the former patch > > Former patch 16: > * Patch 20 - No change (other than merge conflict resolution) > > > John Ferlan (20): > network: Perform some formatting cleanup in bridge_driver.h > network: Use consistent naming in bridge_driver for virNetwork objects > network: Move and rename networkMacMgrFileName > network: Move macmap mgmt from bridge_driver to virnetworkobj > network: Unconditionally initialize macmap when stopping virtual > network > network: Add virNetworkObj Get/Set API's for @dnsmasqPid and @radvdPid > network: Alter virNetworkObj @class_id to be @classIdMap > network: Introduce virNetworkObjGetClassIdMap > network: Add virNetworkObj Get/Set API's for @floor_sum > network: Add virNetworkObj Get/Set API's for @def and @newDef > network: Introduce virNetworkObj{Get|Set}Autostart > network: Introduce virNetworkObj{Is|Set}Active > network: Introduce virNetworkObjIsPersistent > network: Consistent use of @obj for virnetworkobj > network: Have virNetworkObjNew lock the returned object > network: Move virObjectRef during AssignDef processing > network: Use @maxnames instead of @nnames > network: Rename @filter to @aclfilter > network: Modify naming for virNetworkObjList* fetching APIs > network: Privatize virNetworkObj > > src/conf/virnetworkobj.c | 614 +++++++++++++++------- > src/conf/virnetworkobj.h | 105 ++-- > src/libvirt_private.syms | 21 + > src/network/bridge_driver.c | 1218 ++++++++++++++++++++++--------------------- > src/network/bridge_driver.h | 50 +- > src/test/test_driver.c | 83 +-- > src/util/virmacmap.c | 12 + > src/util/virmacmap.h | 4 + > tests/networkxml2conftest.c | 11 +- > 9 files changed, 1231 insertions(+), 887 deletions(-) > Patch 11/20 has an issue, I think some discussion is needed there (also some bug fixing). And I find patch 18/20 not that useful. ACK to the rest though. Michal -- libvir-list mailing list libvir-list@xxxxxxxxxx https://www.redhat.com/mailman/listinfo/libvir-list