On Tue, Jul 14, 2009 at 11:16:09AM +0100, Daniel P. Berrange wrote: > The current libvirtd remote protocol dispatch code is written in > such a way that assumes the only incoming messages from clients > are method calls. This makes it very hard to support data streams. > This patch series does an incrmental refactoring of alot of code > to allow data streams to be easily wired in. > > Daniel P. Berrange (9): > Split generic RPC message dispatch code out from remote protocol API > handlers > Decode incoming request header before invoking dispatch code > Separate code for encoding outgoing remote message headers > Change code generator to give async event messages their own postfix > Move queuing of RPC replies into dispatch code > Change the way client event loop watches are managed > Split out code for handling incoming method call messages > Define an API for registering incoming message dispatch filters > Rename 'direction' to 'type' in remote_message_header All looks fine to me, feel free to push :-) thanks for the neatly splitted patches ! Daniel -- Daniel Veillard | libxml Gnome XML XSLT toolkit http://xmlsoft.org/ daniel@xxxxxxxxxxxx | Rpmfind RPM search engine http://rpmfind.net/ http://veillard.com/ | virtualization library http://libvirt.org/ -- Libvir-list mailing list Libvir-list@xxxxxxxxxx https://www.redhat.com/mailman/listinfo/libvir-list