On 04/25/2017 02:48 PM, Jiri Denemark wrote: > The type of this parameter is virCPUType so calling it 'mode' is pretty > strange, 'type' is a much better name. > > Signed-off-by: Jiri Denemark <jdenemar@xxxxxxxxxx> > --- > src/conf/cpu_conf.c | 6 +++--- > 1 file changed, 3 insertions(+), 3 deletions(-) > > diff --git a/src/conf/cpu_conf.c b/src/conf/cpu_conf.c > index b78531e60..623b1699f 100644 > --- a/src/conf/cpu_conf.c > +++ b/src/conf/cpu_conf.c > @@ -230,7 +230,7 @@ virCPUDefCopy(const virCPUDef *cpu) > virCPUDefPtr > virCPUDefParseXML(xmlNodePtr node, > xmlXPathContextPtr ctxt, > - virCPUType mode) > + virCPUType type) s/type/cputype I have this faint recollection that a variable of name 'type' won't be good for some compiler. John > { > virCPUDefPtr def; > xmlNodePtr *nodes = NULL; > @@ -250,7 +250,7 @@ virCPUDefParseXML(xmlNodePtr node, > if (VIR_ALLOC(def) < 0) > return NULL; > > - if (mode == VIR_CPU_TYPE_AUTO) { > + if (type == VIR_CPU_TYPE_AUTO) { > if (virXPathBoolean("boolean(./arch)", ctxt)) { > if (virXPathBoolean("boolean(./@match)", ctxt)) { > virReportError(VIR_ERR_XML_ERROR, "%s", > @@ -263,7 +263,7 @@ virCPUDefParseXML(xmlNodePtr node, > def->type = VIR_CPU_TYPE_GUEST; > } > } else { > - def->type = mode; > + def->type = type; > } > > if ((cpuMode = virXMLPropString(node, "mode"))) { > -- libvir-list mailing list libvir-list@xxxxxxxxxx https://www.redhat.com/mailman/listinfo/libvir-list