On Wed, Jan 25, 2017 at 03:27:30PM -0500, John Ferlan wrote: > Modify the code to react more like a real HBA -> vHBA creation. > > Currently the code would just modify the input XML definition to > set the name to a wwpn and then modify the scsi_host capability > entry for the defintion to change the scsi_host# and unique_id > before adding that into the node device. > > This patch does things a bit better. It finds and copies a known > existing vHBA (scsi_host11) in the node_device database and modifies > that definition to change the name to scsi_host12 and set the wwnn/ > wwpn to what the input XML would expect before adding the def to the > node device object list. > > Then rather than create a returned "dev" using the (poorly) mocked > name - perform the lookup using the new device name. > > Signed-off-by: John Ferlan <jferlan@xxxxxxxxxx> > --- > src/test/test_driver.c | 75 ++++++++++++++++++++++++++++++++++++-------------- > 1 file changed, 55 insertions(+), 20 deletions(-) ACK Pavel
Attachment:
signature.asc
Description: Digital signature
-- libvir-list mailing list libvir-list@xxxxxxxxxx https://www.redhat.com/mailman/listinfo/libvir-list