On 01/02/2017 09:30 AM, Ján Tomko wrote: > On Fri, Nov 18, 2016 at 09:26:34AM -0500, John Ferlan wrote: >> Remove duplicated code - make one path through >> >> Signed-off-by: John Ferlan <jferlan@xxxxxxxxxx> >> --- >> src/storage/storage_backend_scsi.c | 35 >> +++++++++++------------------------ >> 1 file changed, 11 insertions(+), 24 deletions(-) >> >> diff --git a/src/storage/storage_backend_scsi.c >> b/src/storage/storage_backend_scsi.c >> index 9863880..df48b1a 100644 >> --- a/src/storage/storage_backend_scsi.c >> +++ b/src/storage/storage_backend_scsi.c >> @@ -722,39 +722,26 @@ createVport(virConnectPtr conn, > >> - if (virGetSCSIHostNumber(parent_hoststr, &parent_host) < 0) >> - goto cleanup; >> + if (virGetSCSIHostNumber(parent_hoststr, &parent_host) < 0) >> + goto cleanup; >> >> - /* NOTE: >> - * We do not save the parent_hoststr in >> adapter->data.fchost.parent >> - * since we could be writing out the 'def' to the saved XML >> config. >> - * If we wrote out the name in the XML, then future starts would >> - * always use the same parent rather than finding the "best >> available" >> - * parent. Besides we have a way to determine the parent >> based on >> - * the 'name' field. >> - */ > > Don't we need to preserve this note for future generations? > Sure... Cannot recall what caused me to remove it - over zealous perhaps John >> + if (adapter->data.fchost.parent && !virIsCapableFCHost(NULL, >> parent_host)) { >> + virReportError(VIR_ERR_XML_ERROR, >> + _("parent '%s' specified for vHBA is not vport >> capable"), >> + parent_hoststr); >> + goto cleanup; >> } >> > > ACK > > Jan -- libvir-list mailing list libvir-list@xxxxxxxxxx https://www.redhat.com/mailman/listinfo/libvir-list