Re: [PATCH v2 00/20] Split parsing and defining logic of daemon's logging

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



> Erik Skultety (20):
>   virlog: Rename virLogParse* to virLogParseAndDefine*
>   virlog: Introduce virLogOutputNew
>   virlog: Introduce virLogFilterNew
>   virlog: Introduce virLogFindOutput
>   virlog: Introduce virLogDefineOutputs
>   virlog: Introduce virLogDefineFilters
>   virlog: Introduce virLogNewOutputTo* as a replacement for
>     virLogAddOutputTo*
>   virlog: Take a special care of syslog when setting new set of log
>     outputs
>   virlog: Introduce virLogParseOutput
>   virlog: Introduce virLogParseFilter
>   virlog: Introduce virLogParseOutputs
>   virlog: Introduce virLogParseFilters
>   virlog: Introduce virLogSetOutputs
>   virlog: Introduce virLogSetFilters
>   daemon: Split output parsing and output defining
>   daemon: Split filter parsing and filter defining
>   virlog: Remove functions that aren't used anywhere anymore
>   virlog: Make some of the methods static
>   virlog: Store the journald fd within the output object
>   virlog: Split parsing and setting priority
> 
>  daemon/libvirtd.c         |    8 +-
>  src/libvirt_private.syms  |   10 +-
>  src/locking/lock_daemon.c |    8 +-
>  src/logging/log_daemon.c  |    8 +-
>  src/util/virlog.c         | 1079 ++++++++++++++++++++++++++-------------------
>  src/util/virlog.h         |   61 +--
>  tests/eventtest.c         |    3 +-
>  tests/testutils.c         |   11 +-
>  tests/virlogtest.c        |   10 +-
>  9 files changed, 702 insertions(+), 496 deletions(-)
> 
> -- 
> 2.5.5
> 

So, I made all the requested adjustments, moved patch 19 to in between 1 and 2,
dropped patch 18 completely, kept the introduction of Set{Filters,Outputs} and
actually splitting the logic in separate patches, replaced all the suggested
checks for NULL for ATTRIBUTE_NONNULL, adjusted the callers appropriately and
tested several scenarios to make sure the daemon doesn't crash and pushed the
patches. Anyways, thanks for reviewing the series...aaand brace yourselves -
an increased number of BZs related to logging is coming.

Erik

Attachment: signature.asc
Description: PGP signature

--
libvir-list mailing list
libvir-list@xxxxxxxxxx
https://www.redhat.com/mailman/listinfo/libvir-list

[Index of Archives]     [Virt Tools]     [Libvirt Users]     [Lib OS Info]     [Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Big List of Linux Books]     [Yosemite News]     [KDE Users]     [Fedora Tools]