Review request. -- Prasanna On Thu, Sep 22, 2016 at 1:04 AM, Prasanna Kumar Kalever <prasanna.kalever@xxxxxxxxxx> wrote: > This series run basic sanity and other tests: > 1. make syntax-check > 2. make check > 3. VIR_TEST_VERBOSE=1 ./tests/qemuargv2xmltest > 4. VIR_TEST_VERBOSE=1 ./tests/qemuxml2argvtest > 5. VIR_TEST_VERBOSE=1 ./tests/qemucapabilitiestest > > v5: > Avoild copying variable glusterDebugLevel to disk->src (virStorageSourcePtri), > instead get debug_level from cfg as per Jiri Denemark review on v4 > Thanks Jirka > > v4: > Address comments by peter on v3 > Mostly betterments in naming variables and grouping patterns in Caps by 5 > Thanks to Peter > > v3: > Add patch 2/2 which address capability checks > Changed 'glusterfs_debug_level' to 'gluster_debug_level' agreeing to Peter > Made changes in libvirtd_qemu.aug > Thanks to Peter & Daniel > > v2: > Modify test cases and syntax check changes as suggested by Peter in v1. > Rename qemu_gfapi_debuglevel to glusterfs_debug_level as per Daniel comments. > Fix to make debug_level changes effects on URI along with JSON. > > TODO: > * changes in libvirtd_qemu.aug > Which I don't understand for now > * comment on debug_level variable in storage source > Not sure what is the right place > * Capablities check > > v1: > Initial post > > Prasanna Kumar Kalever (2): > qemu/gluster: add option for tuning debug logging level > qemu_capabilities: Introduce gluster specific debug capability > > src/qemu/libvirtd_qemu.aug | 3 +++ > src/qemu/qemu.conf | 20 ++++++++++++++++++++ > src/qemu/qemu_capabilities.c | 5 +++++ > src/qemu/qemu_capabilities.h | 1 + > src/qemu/qemu_command.c | 19 +++++++++++++++---- > src/qemu/qemu_command.h | 1 + > src/qemu/qemu_conf.c | 3 +++ > src/qemu/qemu_conf.h | 1 + > src/qemu/qemu_hotplug.c | 6 +++--- > .../qemuargv2xml-disk-drive-network-gluster.args | 7 ++++--- > .../qemuxml2argv-disk-drive-network-gluster.args | 12 ++++++------ > tests/qemuxml2argvtest.c | 3 ++- > 12 files changed, 64 insertions(+), 17 deletions(-) > > -- > 2.7.4 > -- libvir-list mailing list libvir-list@xxxxxxxxxx https://www.redhat.com/mailman/listinfo/libvir-list