On Fri, Jun 03, 2016 at 06:42:10 -0400, John Ferlan wrote: > Create helper virStorageBackendCreateQemuImgSetInput to set the input > > Signed-off-by: John Ferlan <jferlan@xxxxxxxxxx> > --- > src/storage/storage_backend.c | 50 +++++++++++++++++++++++++++---------------- > 1 file changed, 31 insertions(+), 19 deletions(-) > > diff --git a/src/storage/storage_backend.c b/src/storage/storage_backend.c > index 4c40e43..4a3c41d 100644 > --- a/src/storage/storage_backend.c > +++ b/src/storage/storage_backend.c > @@ -943,6 +943,7 @@ struct _virStorageBackendQemuImgInfo { > int backingFormat; > > const char *inputPath; > + const char *inputType; This is misleading. That's the string version of 'inputFormat'. I'd call it inputFormatStr if you wan't to store it here. > int inputFormat; > }; > ACK with the tweak -- libvir-list mailing list libvir-list@xxxxxxxxxx https://www.redhat.com/mailman/listinfo/libvir-list