v3: http://www.redhat.com/archives/libvir-list/2016-May/msg00444.html Changes since v3 (by patch)... 1. Separate out the mock for virRandomBytes. I realize this is not the desired state, but figured to at least be prepared for what would be coming as a followup to: http://www.redhat.com/archives/libvir-list/2016-May/msg00735.html that I'd at least adjust the code to follow using a different random number generator (use increasing i instead of just 0xff for all) 2. Changes from code review... Change name from IV to AES, plus others qemuDomainSecretAESSetup is variable based on HAVE_GNUTLS_CIPHER_ENCRYPT Changes to utilize virStringEncodeBase64 Moved qemuDomainSecretSetup into this version (and made i 3. Split out mock (into patch 1) Comment cleanup Still unresolved from code review is a review comment in qemuBuildDriveStr regarding where the desire movement was. There's a very specific order to where the "password-secret=%s," can be placed. It just wasn't clear from the review comment where exactly it was expected to "move" those lines John Ferlan (3): tests: Add mock for virRandomBytes [NOT TO BE PUSHED] qemu: Introduce new Secret AES API's qemu: Utilize qemu secret objects for RBD auth/secret configure.ac | 1 + src/qemu/qemu_alias.c | 23 +++ src/qemu/qemu_alias.h | 2 + src/qemu/qemu_command.c | 122 +++++++++++- src/qemu/qemu_domain.c | 206 ++++++++++++++++++++- ...muxml2argv-disk-drive-network-rbd-auth-AES.args | 31 ++++ ...emuxml2argv-disk-drive-network-rbd-auth-AES.xml | 42 +++++ tests/qemuxml2argvmock.c | 31 +++- tests/qemuxml2argvtest.c | 3 + 9 files changed, 451 insertions(+), 10 deletions(-) create mode 100644 tests/qemuxml2argvdata/qemuxml2argv-disk-drive-network-rbd-auth-AES.args create mode 100644 tests/qemuxml2argvdata/qemuxml2argv-disk-drive-network-rbd-auth-AES.xml -- 2.5.5 -- libvir-list mailing list libvir-list@xxxxxxxxxx https://www.redhat.com/mailman/listinfo/libvir-list