On Wed, Mar 23, 2016 at 03:28:28PM +0300, Sergey Fedorov wrote: > On 23/03/16 08:32, Peter Xu wrote: > > diff --git a/include/sysemu/kvm.h b/include/sysemu/kvm.h > > index 6695fa7..8738fa1 100644 > > --- a/include/sysemu/kvm.h > > +++ b/include/sysemu/kvm.h > > @@ -306,6 +306,15 @@ void kvm_device_access(int fd, int group, uint64_t attr, > > */ > > int kvm_create_device(KVMState *s, uint64_t type, bool test); > > > > +/** > > + * kvm_support_device - probe whether KVM support specific device > > + * > > + * @vmfd: The fd handler for VM > > + * @type: type of device > > + * > > + * @return: true if supported, otherwise false. > > + */ > > +bool kvm_support_device(int vmfd, uint64_t type); > > Why don't name the function like 'kvm_device_supported' to better express its predicative nature? Because I am trying to follow existing naming style, like: "kvm_create_device" (please see above). Thanks. -- peterx -- libvir-list mailing list libvir-list@xxxxxxxxxx https://www.redhat.com/mailman/listinfo/libvir-list