v4: wrong param name in commit msg v3: - use shorter name for param and rename args - move qemuMigrationCookieAddPersistent out from qemuMigrationBakeCookie - rebase to master v2: reimplemented with new migration param Libvirt doesn't allow to specify destination persistent domain configuration. VIR_MIGRATE_PARAM_DEST_XML migration param is used for active configuration and persistent configuration is taken from source domain. The problem is mentioned in this bug: https://bugzilla.redhat.com/show_bug.cgi?id=835300 This patch-set introduces new migration param VIR_MIGRATE_PARAM_PERSIST_XML and implements its support in qemu driver. Dmitry Andreev (2): qemuMigrationCookieAddPersistent: move it out and change argument type qemu: migration: new migration param for persistent destination XML include/libvirt/libvirt-domain.h | 15 ++++++++++ src/qemu/qemu_driver.c | 12 +++++--- src/qemu/qemu_migration.c | 64 ++++++++++++++++++++++++---------------- src/qemu/qemu_migration.h | 2 ++ 4 files changed, 63 insertions(+), 30 deletions(-) -- 1.8.3.1 -- libvir-list mailing list libvir-list@xxxxxxxxxx https://www.redhat.com/mailman/listinfo/libvir-list