This started as a 'simple' change to use virFileRewrite instead of replaceFile (as pointed out by jtomko in his reply to my review comments of the safewrite_str series:) http://www.redhat.com/archives/libvir-list/2016-February/msg01141.html However, as I was looking at the code I thought - well rather than using forward linked lists to store secrets, this code should use the "more normal" VIR_{APPEND|DELETE}_ELEMENT in order to manage the secret list. So I jumped into the rabbit hole and wound my way through the code to get it to a point where it'll look a whole lot like other drivers. FWIW: Not for *this* release, but hopefully the "next" release! John Ferlan (14): secret: Various formatting cleanups secret: Use virFileRewrite instead of replaceFile secret: Rename virSecretEntry secret: Remove local virSecretPtr 'secret' secret: Rename virSecretObjPtr 'entry' to 'secret' secret: Use 'secret' instead of 's' for variable name secret: Rename directory to configDir secret: Adjust logic to build file path in secretLoad secret: Create a 'configFile' in virSecretObj secret: Create a 'base64File' in virSecretObj secret: Introduce listUnlinkSecret secret: Introduce secretAssignDef secret: Rename loadSecrets secret: Introduce virSecretObjList src/secret/secret_driver.c | 640 ++++++++++++++++++++++----------------------- 1 file changed, 315 insertions(+), 325 deletions(-) -- 2.5.0 -- libvir-list mailing list libvir-list@xxxxxxxxxx https://www.redhat.com/mailman/listinfo/libvir-list