On Wed, Feb 03, 2016 at 01:21:53PM +0100, Erik Skultety wrote: > >> > >> -/* Helper to deserialize typed parameters. */ > >> -static int > >> -deserializeTypedParameters(const char *funcname, > > > > What is the point of the funcname parameter? > > Dropping it first would make it easier to unify the code paths. > > Alright, no problem with this one. > > > > >> + /* Deserialise the result. */ > >> + for (i = 0; i < remote_params_len; ++i) { > >> + virTypedParameterPtr param = *params + i; > >> + virTypedParameterRemotePtr remote_param = remote_params + i; > > > > Please use (*params)[i] and remote_params[i]. > > > > About this one, if you meant replacing them everywhere and also removing > those 2 lines ^^above, that would definitely make it less readable. > However, if you meant a replacement within those 2 lines above, that > would leave you with incompatible expressions. > I meant the latter, I just pointed the pointers the wrong way. Jan
Attachment:
signature.asc
Description: Digital signature
-- libvir-list mailing list libvir-list@xxxxxxxxxx https://www.redhat.com/mailman/listinfo/libvir-list