On Fri, 2015-12-04 at 09:46 +0100, Andrea Bolognani wrote: > On Thu, 2015-12-03 at 14:06 -0500, Laine Stump wrote: > > Instead of creating this new function, how about if we change > > virPCIDevice to contain a virPCIDeviceAddress rather than individual > > domain, bus, slot, and function? > > I think you already mentioned doing so in the past, and it's > definitely a good idea. > > I'll get to it. After the change, we'll be able to just use > > virPCIDeviceAddressIOMMUGroupIterate(virPCIDeviceGetAddress(dev), > actor, > data); > > with virPCIDeviceGetAddress() returning a pointer to the > address stored inside the device instead of a newly-allocated > object. Hi Laine, while I explore this, is there any chance you can take a look at the rest of the series and confirm that at least the base idea is sound? I've tried to break it down into easily digestible chunks and include plenty of comments so that hopefully getting a bird view is possible without having to do a full review. I'd very much value this kind of early feedback, even with the series still missing a couple of bits. At least the first three patches are really standalone cleanups, so maybe those could go in even without the rest? That would reduce the series size a tiny bit. Cheers. -- Andrea Bolognani Software Engineer - Virtualization Team -- libvir-list mailing list libvir-list@xxxxxxxxxx https://www.redhat.com/mailman/listinfo/libvir-list