On Wed, Jan 28, 2009 at 07:46:34PM +0100, Jim Meyering wrote: > "Daniel P. Berrange" <berrange@xxxxxxxxxx> wrote: > > On Tue, Jan 20, 2009 at 11:08:56PM +0000, Daniel P. Berrange wrote: > >> This patch adds support for using the monitor interface to set the VNC > >> password > >> > >> (qemu) change vnc password > >> Password: ******** > >> > >> A minor tricky thing is that we can't just send the command and password > >> all in one go, we must wait for the 'Password' prompt before sending the > >> password. > >> > >> When doing this I noticed that virsh dumpxml has no way to request a > >> secure XML dump (required to see the password element), nor did the > >> virsh edit command set the SECURE or INACTIVE flags when changing > >> the XML. > >> > >> qemu_conf.c | 45 ++++++++++++----------- > >> qemu_driver.c | 112 ++++++++++++++++++++++++++++++++++++++++++++-------------- > >> virsh.c | 30 ++++++++++----- > >> 3 files changed, 131 insertions(+), 56 deletions(-) > ... > > + int flags = 0; > > + int inactive = vshCommandOptBool(cmd, "inactive"); > > + int secure = vshCommandOptBool(cmd, "secure"); > > + > > + if (inactive) > > + flags |= VIR_DOMAIN_XML_INACTIVE; > > + if(secure) > > + flags |= VIR_DOMAIN_XML_SECURE; > > ACK. > My only reservation is that this new --secure option currently means > "also dump sensitive info" (passwords), which is sometimes > _in_secure. So how about naming it --all instead? How about --security-info ? I think --all is probably a little too generic a term Daniel -- |: Red Hat, Engineering, London -o- http://people.redhat.com/berrange/ :| |: http://libvirt.org -o- http://virt-manager.org -o- http://ovirt.org :| |: http://autobuild.org -o- http://search.cpan.org/~danberr/ :| |: GnuPG: 7D3B9505 -o- F3C9 553F A1DA 4AC2 5648 23C1 B3DF F742 7D3B 9505 :| -- Libvir-list mailing list Libvir-list@xxxxxxxxxx https://www.redhat.com/mailman/listinfo/libvir-list