On 06/24/2015 10:11 AM, Peter Krempa wrote: > Version 2 has a few more fixes as suggested by Michal. > > Peter Krempa (15): > test: Rename testConn to testDriver > test: Drop useless forward declaration > test: turn 'defaultConn' into a pointer > test: Extract code to free testDriver into testDriverFree > test: Extract common parts of test driver data allocation > test: Drop unused attribute @path from testDriver struct > test: Annotate few fields of testDriver structure > test: Use atomic access to @nextDomID in struct virTestDriver > test: Refactor test driver event sending > test: Finalize removal of locking from driver->eventState > test: Drop locked access to testDriver->domains > test: Refactor test driver domain object retrieval > test: Refactor testDomainSetVcpusFlags > test: Refactor vcpu pinning and vcpu info retrieval > test: Refactor testNodeGetCPUMap > > src/test/test_driver.c | 1305 +++++++++++++++--------------------------------- > 1 file changed, 401 insertions(+), 904 deletions(-) > Other than a couple of things pointed out things seem reasonable to me ACK John -- libvir-list mailing list libvir-list@xxxxxxxxxx https://www.redhat.com/mailman/listinfo/libvir-list