On 03/25/2015 05:21 PM, John Ferlan wrote: > In a bit of bikeshedding - this patch does a couple of things and could > be split into a couple of patches... Ironically you bundled things > together here, but separated them for the stateDir changes (patches 2, > 4, & 7). > > first one just creates DefFormatBuf and has DefFormat call it > > second one creates the virStoragePoolSaveXML, has the config code use it > > third one creates virStoragePoolSaveStatus which use the new API's Nice ideas, I'll rework the patch. >> + virBufferAddLit(&buf, "<poolstatus>\n"); > > poolstate ? > >> + virBufferAdjustIndent(&buf, 2); >> + >> + if (virStoragePoolDefFormatBuf(&buf, def) < 0) >> + goto error; >> + >> + virBufferAdjustIndent(&buf, -2); >> + virBufferAddLit(&buf, "</poolstatus>\n"); > > poolstate ? > Hmm, I see your point, however I had a look at the network state file and it's formatted as <networkstatus>. The question is if we want to stay consistent one way or another, or we don't want to care about this particular detail at all.... Erik -- libvir-list mailing list libvir-list@xxxxxxxxxx https://www.redhat.com/mailman/listinfo/libvir-list