On Tue, Jun 3, 2014 at 10:16 AM, Christophe Fergeau <cfergeau@xxxxxxxxxx> wrote: > We were only passing libvirt-gobject-domain.h and > libvirt-gobject-connection.h through glib-mkenums, which causes it to > only generate GEnum information for enums found in these headers. > We want to do that for all enums defined in installed headers, so > passing all headers listed in libvirt_gobject_1_0_la_HEADERS is more > appropriate. ACK if your patch doesn't introduce any warnings/errors. > --- > libvirt-gobject/Makefile.am | 4 ++-- > libvirt-gobject/libvirt-gobject.sym | 5 +++++ > 2 files changed, 7 insertions(+), 2 deletions(-) > > diff --git a/libvirt-gobject/Makefile.am b/libvirt-gobject/Makefile.am > index 516c10f..7163c7d 100644 > --- a/libvirt-gobject/Makefile.am > +++ b/libvirt-gobject/Makefile.am > @@ -93,7 +93,7 @@ libvirt_gobject_1_0_la_LDFLAGS = \ > -Wl,--version-script=$(srcdir)/libvirt-gobject.sym \ > -version-info $(LIBVIRT_GLIB_VERSION_INFO) > > -libvirt-gobject-enums.c: libvirt-gobject-domain.h libvirt-gobject-connection.h > +libvirt-gobject-enums.c: $(libvirt_gobject_1_0_la_HEADERS) > $(AM_V_GEN)glib-mkenums \ > --fhead "#include \"libvirt-gobject/libvirt-gobject.h\"\n\n" \ > --vhead "static const G@Type@Value _@enum_name@_values[] = {" \ > @@ -106,7 +106,7 @@ libvirt-gobject-enums.c: libvirt-gobject-domain.h libvirt-gobject-connection.h > --vtail " return type;\n}\n\n" \ > $^ | sed -e 's/g_vir/gvir/g' > $@ > > -libvirt-gobject-enums.h: libvirt-gobject-domain.h libvirt-gobject-connection.h > +libvirt-gobject-enums.h: $(libvirt_gobject_1_0_la_HEADERS) > $(AM_V_GEN)glib-mkenums --fhead "#ifndef __LIBVIRT_GOBJECT_ENUMS_H__\n" \ > --fhead "#define __LIBVIRT_GOBJECT_ENUMS_H__\n\n" \ > --fhead "G_BEGIN_DECLS\n\n" \ > diff --git a/libvirt-gobject/libvirt-gobject.sym b/libvirt-gobject/libvirt-gobject.sym > index b781cc6..4e856e7 100644 > --- a/libvirt-gobject/libvirt-gobject.sym > +++ b/libvirt-gobject/libvirt-gobject.sym > @@ -237,6 +237,11 @@ LIBVIRT_GOBJECT_0.1.5 { > LIBVIRT_GOBJECT_0.1.9 { > global: > gvir_domain_snapshot_delete; > + gvir_domain_snapshot_delete_flags_get_type; > + gvir_storage_pool_state_get_type; > + gvir_storage_vol_resize_flags_get_type; > + gvir_storage_vol_type_get_type; > + gvir_stream_io_condition_get_type; Are these related? Shouldn't this change be split? Regards, Zeeshan Ali (Khattak) ________________________________________ Befriend GNOME: http://www.gnome.org/friends/ -- libvir-list mailing list libvir-list@xxxxxxxxxx https://www.redhat.com/mailman/listinfo/libvir-list