On Thu, Oct 02, 2008 at 03:06:01PM +0200, Daniel Veillard wrote: > On Wed, Sep 24, 2008 at 10:55:36AM -0700, Ian Main wrote: > > > > Howdy folks! > > > > If you wish to try it out, I've made rpms for fedora 9 x86_64 and i386. > > They are in the ovirt repo, which you can add to yum using: > > > > rpm -ivh http://ovirt.org/repos/ovirt/9/ovirt-release-LATEST.fc9.noarch.rpm > > Note to interested users, you also need to enable the repo > by editing /etc/yum.repos.d/ovirt.repo after install and switch enable > to 1 at least in the first section. > > > Once you have that set up, 'yum install libvirt-qpid python-qpid', and then > > run (each in their own terminals): > > You also need 'yum install qpidd' I suspect this indicates a missing > dependancy maybe in the libvirt-qpid package but I'm not 100% sure Yeah, i believe that should be a requirement. NB, the versions of qpidc and qpidd in Fedora currently are too old for libvirt-qpid. I've been speaking with qpid maintainer and they'll push a new build to Fedora in the very near future. > > > qpidd --auth no > > libvirt-qpid (as root to auth with libvirt) > > qpid-tool > > > > qpid-tool provides an interface to qpid and allows you to view/manipulate the > > qpid models/objects. Here is an example of how it looks using qpid-tool: > > > > $ qpid-tool > > Management Tool for QPID > > qpid: list > > Well ... all I got there was > > Waiting for next periodic update > > on the other hand the libvirt-qpid is checking every second or so the > current state, I guess the connection isn't made or something. > I tried qpid-tool both as root and $user > > BTW i would suggest to rename qpid-tool to libvirt-qpid-tool or > virt-qpid-tool to avoid confusion about the scope. Actually qpid-tool is a general purpose shell provided by qpid themselves, not a libvirt specific thing - if you have other agents active it'll show those objects as wel as the libvirt ones. > > Some comments about the XML schemas: > - camelCaseDanke :-) > - Node has methods domain_define_xml, storage_pool_define_xml and > storage_pool_create_xml > I think at least for symetry domain_create_xml should be available > there too. Yep, all APIs should be expressed in the qpid binding eventually. > - I would make an Error class mimicking at least partially what's > available in libvirt C or python bindings > - Domain.create() is very confusing, again I would define domain > creation under node, i.e. temporary 'undefined' domains. Then > <method name="create" desc="Start stopped VM"/> > should probably be renamed 'start' to avoid confusion. > and the comment "Start a defined but stopped domain" would be more > adequate by mentioning the define API... The trouble with that is it would diverge from libvirt naming - admittedly the libvirt naming isn't ideal, but i figure consistency is better so people can cross-reference API documentation more easily. So the 'create' method on Domain does make sense, but we'd expect another 'createLinux' method on the Node object for unmanaged domains - though it might be worth breaking with consistency in this one case and dropping the 'Linux' suffix from the name there . Daniel -- |: Red Hat, Engineering, London -o- http://people.redhat.com/berrange/ :| |: http://libvirt.org -o- http://virt-manager.org -o- http://ovirt.org :| |: http://autobuild.org -o- http://search.cpan.org/~danberr/ :| |: GnuPG: 7D3B9505 -o- F3C9 553F A1DA 4AC2 5648 23C1 B3DF F742 7D3B 9505 :| -- Libvir-list mailing list Libvir-list@xxxxxxxxxx https://www.redhat.com/mailman/listinfo/libvir-list